Formeln und Funktionen – digibasics
Version 1.0
Prototyp zur Erprobung

Formeln und Funktionen

4.1
Formeln mit Zellbezügen und arithmetischen Operatoren erzeugen

Formeln

Formeln werden in der Bearbeitungsleiste eingegeben und beginnen immer mit dem Gleichheitszeichen (=). Dabei kannst du Excel wie einen Taschenrechner verwenden: Gib die Rechnung direkt ins Eingabefeld der Bearbeitungsleiste und drücke dann die Zeilenschaltung auf der Tastatur (oder klicke auf das für Eingeben).

Zellbezüge

Viel besser ist es jedoch, die Operanden auf einzelne Zellen zu verteilen, die Formel in einer weiteren Zelle einzugeben und dabei mit Zellbezügen zu arbeiten. So enthält die Formel keine festen Werte, sondern Variablen (die Zellbezüge):

Auf diese Weise lässt sich die Rechenoperation auf beliebige Werte anwenden, die in den Zellen A1, B1 und C1 stehen. Ein weiterer Vorteil: Wenn die Zelle, die die Formel enthält, kopiert wird, passt Excel die Zellbezüge automatisch an. Aus =A1*B1+C1 wird A2*B2+C2, A3*B3+C3 usw.

Grundoperationen in Excel

OperationOperatorBeispiel
Addition+=23+7
Subtraktion=99-11
Multiplikation*=9*8
Division/=32/4
Potenzierung^=5^3

In Formeln gelten die bekannten mathematischen Regeln. Multiplikation und Division haben Vorrang vor Addition und Subtraktion. Verwende ggf. Klammern:

  • 12*4-2=46 aber: 12*(4-2)=24
  • 72/3+3=27 aber 72/(3+3)=8

So gibst du eine Formel mit Zellbezügen ein (hier am Beispiel des Satzes von Pythagoras):

  1. Klicke in die Zelle, die die Formel enthalten soll (hier: C4).
  2. Gib das Gleichheitszeichen = ein.
  3. Klicke auf die Zelle, die den Wert für a enthalten soll (hier: A4).
  4. Gib den Operator * ein und klicke erneut auf die Zelle für a.
  5. Klicke auf die Zelle, die den Wert für b enthalten soll (hier: B4).
  6. Gib den Operator * ein und klicke erneut auf die Zelle für b.
  7. Drücke die Zeilenschaltung, um die Formel abzuschliessen.
  8. Gib Werte in die Zellen A4 und B4 ein. In Zelle C4 wird das Ergebnis der Formel angezeigt.
  9. Fülle die Datenreihen in den Spalten A und B aus (hier: mit Intervall 2 für Spalte A, mit Intervall 4 für Spalte B).
  10. Kopiere die Zelle C4 in die darunterliegenden Zellen. Die Zellbezüge werden automatisch angepasst.

4.2
Fehlermeldungen von Formeln verstehen

Wenn Formeln Fehler enthalten, schreibt Excel folgende Meldungen in die fehlerhafte Zelle:

FehlermeldungUrsacheBeispiel
 #NAME?Fehlerhafter Formelname=SUME(A1:A12)
statt SUMME
#DIV/0!Division durch Null=A12/C3
wobei C3 den Wert 0 enthält.
#WERT!Rechenoperation mit einer Zelle, die Text statt einer Zahl enthält.=A1+B1
wobei A1 Text enthält.
#BEZUG!Formel bezieht sich auf eine ungültige Zelle.=B2/C1
wobei Zelle B2 gelöscht wurde.

4.3
Relative und absolute Zellbezüge in Formeln verwenden

Relativer Bezug

Standardmässig ist ein Zellbezug ein relativer Bezug, d.h. relativ zur Position der Zelle. Wenn du eine Zelle kopierst, die Zellbezüge enthält, und an anderer Stelle einfügst, passt Excel die Bezüge automatisch an:

Absoluter Bezug

Es gibt aber Situationen, in denen diese automatische Anpassung nicht sinnvoll ist, wie im folgenden Beispiel:

Die Währungsumrechnung verwendet den Wechselkurs in Zelle E3, und zwar in allen kopierten Formeln. In diesem Fall macht man den Bezug absolut, indem man ein $ vor den Spaltenbuchstaben und vor die Zeilennummer setzt:

  • relativer Bezug: E3
  • absoluter Bezug: $E$3


4.4
Einfache Funktionen verwenden (Summe, Mittelwert, Minimum, Maximum, Anzahl, Runden)

Aufbau einer Funktion

Excel stellt eine Vielzahl an Funktionen bereit. Jede Funktion ist so aufgebaut:

Die Anzahl der Argumente hängt von der Funktion ab. Argumente können Zellbezüge, Zahlen oder Texte sein. Funktionen ohne Argument haben eine leere Klammer. Beispiele:

  • Kein Argument: =PI() – Gibt die Kreiszahl π aus.
  • Ein Argument: =SUMME(B2:B14) – Der Zellbereich (B2:B14) gilt als ein Argument, nicht zwei!
  • Zwei Argumente: =RUNDEN(B2;3)
  • Drei Argumente: =WENN(C2>50;»Test bestanden»;»Test nicht bestanden») – Siehe dazu 4.5 WENN-Funktion mit Vergleichsoperator verwenden.

Beim Einfügen einer Funktion zeigt Excel, welche Argumente die Funktion benötigt:

Funktion einfügen

So fügst du die Funktion MEDIAN ein:

  1. Wähle die Zelle aus, die die Funktion enthalten soll.
  2. Klicke in der Bearbeitungsleiste auf Funktion einfügen.
  3. Suche nach der Funktion MEDIAN (oder wähle eine Kategorie aus).
  4. Wähle die Funktion in der Liste aus und klicke auf OK.
  5. Klicke auf den Aufwärtspfeil neben dem ersten Argument und wähle die Zelle bzw. den Zellbereich aus.
  6. Wiederhole Schritt 5 für das zweite Argument.
  7. Klicke auf OK.

Häufig gebrauchte Funktionen sind im Menüband Start im Aufklappmenü mit dem Summenzeichen zu finden.

Funktion SUMME verwenden

So fügst du die Funktion für die Summe von Zahlen ein:

  1. Wähle die Zelle aus, die die Funktion enthalten soll.
  2. Klicke im Menüband Start auf das Aufklappmenü
  3. Wähle Summe. Die Funktion =SUMME(…) wird mit einem provisorischen Argument eingesetzt. Das Argument ist ausgewählt, damit du es im nächsten Schritt ersetzen kannst.
  4. Wähle die Zellen aus, die das provisorische Argument ersetzen sollen, und drücke die Zeilenschaltung.

Wiederhole diese Schritte für Mittelwert, Anzahl Zahlen, Max und Min.

Funktion RUNDEN verwenden

Mit der Funktion =RUNDEN(Zahl;Anzahl_Stellen) kannst du eine Dezimalzahl auf eine bestimmte Anzahl Stellen runden:

So rundest du auf 5 Rappen: =RUNDEN(Zahl*2;1)/2


4.5
WENN-Funktion mit Vergleichsoperator verwenden

Die WENN-Funktion erlaubt es, den Inhalt einer Zelle von einer Bedingung abhängig zu machen. Im folgenden Beispiel wird aufgrund der Punktzahl (in Spalte C) ein Text in Spalte D ausgegeben: Wenn die Punktzahl grösser als oder gleich 75 ist, wird «Bestanden» ausgegeben, sonst «Nicht bestanden».

Die Funktion lautet: =WENN(Bedingung;wahr;falsch). Beachte die Semikolons. Der anzuzeigende Text muss in Anführungszeichen geschrieben werden.

So gibst du eine WENN-Funktion in eine Zelle ein und kopierst sie:

  1. Klicke in die Zelle, die die Formel enthalten soll (hier: D4).
  2. Gib die WENN-Funktion ein: =WENN(C4>=$F$3;“Bestanden“;“Nicht bestanden“)
  3. Beachte den absoluten Bezug auf Zelle F3, die den Schwellenwert enthält.
  4. Wähle die Zelle aus, die die Formel enthält, und kopiere sie in die darunterliegenden Zellen.
  5. Gib einen anderen Schwellenwert ein und beobachte die Veränderung der Texte in der Spalte D.

4.6
Zellen mit Namen versehen bzw. Namen löschen

Zellen und Zellbereiche lassen sich mit einem Namen versehen. Dies erleichtert die Lesbarkeit von Formeln. Ein Bezug auf eine benannte Zelle ist absolut, d.h. beim Kopieren bleibt der Bezug auf die benannte Zelle erhalten. In der folgenden Formel ist Limite gleichbedeutend mit $G$4.

Es ist gute Praxis, eine Zelle mit Namen zu versehen, wenn andere Zellen einen absoluten Bezug auf diese Zelle haben. Zellnamen machen Formeln lesbarer und helfen bei der Fehlersuche.

So gibst du einer Zelle einen Namen und verwendest ihn in einer Formel:

  1. Wähle die Zelle aus.
  2. Gib im Namenfeld einen Namen für die Zelle ein (hier: Limite) und drücke die Zeilenschaltung.
  3. Wähle eine andere Zelle für die Formel aus.
  4. Verwende in der Formel den Namen der Zelle statt des gewohnten Zellbezugs (hier: $G$3). Beim Kopieren der Formel in andere Zellen bleibt der absolute Bezug auf die benannte Zelle erhalten.

So löschst du einen Zellnamen:

  1. Klicke im Menüband Formeln auf den Namens-Manager.
  2. Wähle den Namen in der Liste aus und klicke auf Löschen.
  3. Bestätige das Löschen mit Klick auf OK und schliesse den Namens-Manager. Alle Zellen, die diesen Namen in ihrer Formel verwenden, zeigen nun den Fehler #NAME? an.

4.7
Beim Kopieren von Zellinhalten statt Formeln Werte einfügen

Eine Zelle enthält oft mehrere Dinge: eine Formel, einen (berechneten) Wert und eine Formatierung:

Wenn du eine solche Zelle kopierst und an anderer Stelle einfügst musst du entscheiden, ob die Formel oder der Wert eingefügt werden soll und dies mit oder ohne Formatierung.

Excel bietet dazu folgende Einfügeoptionen, die auf den ersten Blick etwas verwirrend scheinen:

Bei berechneten Werten macht es keinen Sinn, die kopierte Formel einzufügen, da die Zellbezüge danach nicht mehr stimmen. Stattdessen fügst du nur die Werte ein – mit oder ohne Formatierung.

So fügst du die Werte von kopierten Zellen ein:

  1. Wähle die Zellen aus, deren Werte du kopieren willst.
  2. Wähle im Menüband Start den Befehl Kopieren oder drücke Controltaste + C (Windows) bzw. Befehlstaste + C (macOS) auf der Tastatur.
  3. Rechtsklicke in die Zelle, ab der du die Werte einfügen willst.
  4. Wähle im Kontextmenü den Befehl Inhalte einfügen und wähle unter Werte einfügen eine der drei Optionen:
    • Werte Setzt die Werte im Standardformat ein (hier: mit allen Dezimalstellen).
    • Werte und Zahlenformat Setzt die Werte mit dem Zahlenformat der Ursprungszellen ein (hier: benutzerdefiniert ohne Dezimalstellen).
    • Werte und Quellformatierung→ Setzt die Werte mit dem Zahlenformat und der Formatierung der Ursprungszellen ein (hier: gelber Zellhintergrund und Rahmenlinien).